Jump to content
  • Welcome to the Ford Fusion Forum

    To enjoy the Ford Fusion Forum's content, please click here to create an account.

  • Custom Search


Sign in to follow this  
MTDAve06

Canister Purge Valve issues?

Recommended Posts

I have a 2015 Ford Fusion with the 2.0L Ecoboost w/ AWD and 28,750 miles. Last week my check engine light came on, so I had the code looked at and got a P144A.

After some light research that tells me the Canister Purge Valve/Solenoid is a very common culprit after Ford changed their design to 1 piece across all models after 2009. It will stick open and dump 40% extra gas down the drain OR stick closed and kill the vehicle while running.

SO here's the deal - The vehicle is for my Fiancee which she uses for work, our newborn and our 2 daughters. I know its under warranty, but they cannot get me in for almost a week at my local dealer. So if at all possible id like to try to fix it myself. from 2009-2013 its fairly easily located in the engine bay.

WHERE IS IT LOCATED? All of my research gives me ZERO information on where to find it. 6 hours looking in the engine bay, and the ford part website image for the specific part shows near the gas tank. Can't see it anywhere. I can't keep having it die on them and leave work to get them, or vice versa if we switch vehicles. I have the new valve and I'd love to just fix it myself if at all possible.

Any ideas or help?

Share this post


Link to post
Share on other sites

I don't know if its the same but just had similiar issue on my 2013 Ford Escape.

 

The purge valve did not come separately but was part of a hose assembly.

 

Here is a thread from the Escape BB.

 

http://www.fordescape.org/forum/engine-technical-discussion/75697-vapor-canister-purge-valve-ford-part-cv6z-9d289-r.html#post814081

 

Good luck,

 

Vin

Share this post


Link to post
Share on other sites

My 2014 fufsion fwd titanium with 59k miles just got this error thursday night. I found the purge valve but it did not look anything like the ford part number, so I went ahead and bought the entire assembly from my ford dealer, $110

 

I've seen lots of posts that claim its a 10 minute job and its under the hood, and some others claiming its near the gas tank and the entire sub frame has to be removed.

 

I'll poke around under my hood tonight and see, hopefully its under there.

 

I'm a little disappointed in the fact that this car is 2 years old and just exhibited a breakdown.

 

Also, I noticed that I could not use my remote start this morning (22 degrees yuck!) Does a check engine light prevent the remote start?

 

 

Share this post


Link to post
Share on other sites

I assume you've fixed this by now, but for anyone else looking for the same answer:

 

https://app.box.com/s/uw27oc8id21l1xetg98meh5l4pxb0gxc

 

And a closer shot:

 

https://app.box.com/s/nshnizgqh8ezathsuo64erlubrsgexou

Share this post


Link to post
Share on other sites

I have a 2015 Ford Fusion with the 2.0L Ecoboost w/ AWD and 28,750 miles. Last week my check engine light came on, so I had the code looked at and got a P144A.

 

After some light research that tells me the Canister Purge Valve/Solenoid is a very common culprit after Ford changed their design to 1 piece across all models after 2009. It will stick open and dump 40% extra gas down the drain OR stick closed and kill the vehicle while running.

 

SO here's the deal - The vehicle is for my Fiancee which she uses for work, our newborn and our 2 daughters. I know its under warranty, but they cannot get me in for almost a week at my local dealer. So if at all possible id like to try to fix it myself. from 2009-2013 its fairly easily located in the engine bay.

 

WHERE IS IT LOCATED? All of my research gives me ZERO information on where to find it. 6 hours looking in the engine bay, and the ford part website image for the specific part shows near the gas tank. Can't see it anywhere. I can't keep having it die on them and leave work to get them, or vice versa if we switch vehicles. I have the new valve and I'd love to just fix it myself if at all possible.

 

Any ideas or help?

 

 

Did you ever get this issue resolved? I am having the same issue and would like to fix it myself if possible.

 

Thanks!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×