Jump to content
  • Welcome to the Ford Fusion Forum

    To enjoy the Ford Fusion Forum's content, please click here to create an account.

  • Custom Search


Brad65

LED MAP LIGHTING ISSUE

Recommended Posts

10Dec16

I replaced the factory map lights with LED ones , but now they wont turn on when the car is running, when i push the switch. When the is off they will they turn on, when i open the doors and the trunk light and the mirror linghts do not turn on at all. How ever I did not change trunk or mirror to LED as of yet , and wasn't sure if that issue was related. Thank you

Share this post


Link to post
Share on other sites

I would put the old bulbs back in and see if the issue persists.

Share this post


Link to post
Share on other sites

Ypu blew a fuse in the SJB. 10A

Share this post


Link to post
Share on other sites

Probably a resistance issue. Sometimes if you put too many LEDS in the system, it will freak out. One or two, all is well. Hopefully did not blow a fuse, that would not be good. Definitely put back the stock bulbs and see what happens. Do you have the technical specs for the LEDs you have installed?

Share this post


Link to post
Share on other sites

It is F25 in the SJB. Probably nothing wrong with the LED's.

Sometimes you can short the + side feed to ground if you aren't careful when installing bulbs.

The trunk light is especially easy to short by its design.

Share this post


Link to post
Share on other sites

Thanks for the all the info it was after all a 10a fuse , #25again thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×